Compatibility matrix

The Europass Compatibility matrix provides an overview of the current compatibility between the Europass XML/JSON versions and the various Europass services.

  New CV editor New LP editor

Old CV editor

Deprecated

Old LP Editor

Deprecated

Remote Upload v1 REST API v1

SOAP API v2

Deprecated

SOAP API v1

Deprecated

XML v3.x.x Upload / Download Upload / Download N/A N/A Upload / Download Send / Receive N/A N/A
XML v2.0 Upload / Download v3.x.x Upload / Download v3.x.x Upload / Download Upload / Download Upload / Download v3.x.x Send / Receive v3.x.x Send / Receive Send / Receive
XML v1.2 Upload / Download v3.x.x Upload / Download v3.x.x Upload / Download v2.0 Upload / Download v2.0 Upload / Download v3.x.x Send / Receive v3.x.x Send / Receive v2.0 Send / Receive v2.0
XML v1.1 Upload / Download v3.x.x Upload / Download v3.x.x Upload / Download v2.0 Upload / Download v2.0 Upload / Download v3.x.x Send / Receive v3.x.x Send / Receive v2.0 Send / Receive v2.0
XML v1.0 Upload / Download v3.x.x Upload / Download v3.x.x Upload / Download v2.0 Upload / Download v2.0 Upload / Download v3.x.x Send / Receive v3.x.x Send / Receive v2.0 Send / Receive v2.0
JSON v3.x.x N/A N/A N/A N/A N/A Send / Receive N/A N/A

JSON v2.0

Deprecated

N/A N/A N/A N/A N/A N/A Send / Receive N/A

Important reminders:

  • All Europass documents are based on one common XML schema and therefore can be uploaded to any of the available services provided they are version-compatible (e.g. a CV can be uploaded to the LP editor and vice versa).
  • Most services are backward compatible but not forward compatible. That is, an older XML or JSON version can be uploaded to a newer service (in which case it will be converted automatically to the latest version before being processed) but a newer XML/JSON cannot be uploaded to an older service.
  • Backward compatibility follows a "best effort" approach, meaning that in some cases it is not possible to convert the data to a newer version exactly as is due to structural differences.
  • XML versions older than v3.x.x cannot be directly sent as input to the REST API v1. However, they can be converted to v3.x.x using either the XML Upgrade REST service or one of the available XSL transformations.
  • As is the case with older XML versions, JSON v2.0 documents cannot be directly sent as input to the REST API v1.
  • You might also want to check the note on XML versions and compatibility as well as JSON versions and compatibility.

 

Was this page helpful?
Let us know how we did